안드로이드 스튜디오 Configuration... 오류 해결하기

한동안 블로그에 포스팅만 작성하다가 오랫만에 안드로이드 스튜디오를 실행해 보니 버전 업데이트가 꽤나 있더군요. 모든 업데이트를 진행하고 예전에 작업했던 앱을 불러오니 오류가 발생되는걸 보았습니다. "Configuration 'compile' is obsolete and has been replaced with 'implementation' and 'api'.

It will be removed at the end of 2018. For more information see:" 이런 오류였는데요. 해결하는 방법을 알아보도록 하겠습니다.


오류가 발생되는걸 하나하나 해결하는 재미가 있는게 저만 그런건 아니죠?



Configuration... 오류

오랫만에 불러온 어플리케이션이 컴파일 완료가 되고나서 붉은색 동그라미로 오류가 있다는걸 알려주고 있습니다.

오른쪽을 보니 이런 오류가 발생되고 있었는데요. 알고보니 최신 버전으로 업데이트가 되고나서 코드가 변경되어 발생하는 오류였습니다. 이제 해결을 하는 방법을 알아보도록 하겠습니다.




오류 해결하기

코드를 변경해야 하는 위치는 바로 이미지에 붉은색으로 표시한 "compile" 입니다.

"compile" 코드를 "implementation" 코드로 변경해 주시고 위쪽에 Sync Now를 클릭하면

오류가 발생되지 않는것을 확인하실 수 있습니다. "compile" 코드를 "implementation" 코드로 변경하는 방법은 사실 위쪽에 첨부한 오류 이미지에서 확인할 수 있는데요. 영어로 작성되어 있어서 저는 보고도 몰랐습니다.


이 글을 공유하기

댓글(0)

Designed by JB FACTORY